Investigating Degraded Performance for Elvanto
Incident Report for Elvanto
Resolved
All buttons in Elvanto should now be functioning as expected. Thank you for your patience!
Posted Sep 26, 2023 - 16:42 PDT
Update
Our Engineering team was able to resolve this issue earlier today. All pages / buttons are working as expected.
Posted Sep 26, 2023 - 16:41 PDT
Update
We are continuing to investigate the root cause of buttons not functioning as expected.
Posted Sep 26, 2023 - 12:47 PDT
Investigating
We’re noticing that Save/send buttons, generate buttons, and other buttons across Elvanto are not functioning as expected. Our Engineers have been engaged, and are currently investigating.
Posted Sep 26, 2023 - 09:22 PDT