Issues with registration forms using the Tithely Payment Gateway

Incident Report for Elvanto

Resolved

Our Engineering team has fully resolved the troubles and we are seeing that registrations using the Tithely Payment Gateway are working as expected.
Posted Jul 04, 2024 - 07:25 PDT

Identified

The issue has been identified and we are implementing a solution right now.
Posted Jul 04, 2024 - 07:00 PDT

Investigating

We are aware of an issue with Elvanto form registrations using the Tithely Payment Gateway and we are investigating.
Posted Jul 04, 2024 - 06:27 PDT
This incident affected: Web Application (Australia & New Zealand, International, United States).