Investigating Partial Outage for Elvanto Reports
Incident Report for Elvanto
Resolved
We’re back! Reports should be up and running. Thanks for bearing with us.
Posted Nov 13, 2023 - 22:26 PST
Investigating
We’re noticing issues loading reports for some users. We’re investigating the root problem right now. We’ll continue to share updates on our progress as we resolve this issue.
Posted Nov 13, 2023 - 22:13 PST
This incident affected: Web Application (Australia & New Zealand, International, United States).