Previously sent emails sending again
Incident Report for Elvanto
Resolved
Our Engineering team was able to resolve this issue for all Elvanto Servers. Thank you for your patience!
Posted Apr 08, 2024 - 07:58 PDT
Identified
Our Engineering team has identified the source of the email issue and is working on a resolution.
Posted Apr 08, 2024 - 06:53 PDT
Investigating
Our team is aware of a new issue where some previously sent emails are sending again. We're investigating and will provide another update soon.
Posted Apr 08, 2024 - 04:14 PDT
This incident affected: Web Application (Australia & New Zealand, International, United States).