This incident has been resolved. The Elvanto app is live for both apple and android products.
Posted Sep 04, 2025 - 12:17 PDT
Monitoring
To fully solve this issue we needed to release new versions of the Elvanto App. This new version of the Elvanto app has been approved by the Apple App store so any users on iOS can update their Elvanto app which will resolve the problem.
We're awaiting approval through the Google Play store and will update once we have further information.
Posted Aug 23, 2025 - 04:34 PDT
Update
We've confirmed there is an issue with an upstream provider that is causing issues in the Elvanto App. We encourage you to use Elvanto directly from your device's browser as we continue work to fully resolve this issue.
Posted Aug 20, 2025 - 17:25 PDT
Investigating
Our teams are aware of an issue affecting the loading of the Elvanto App. This appears to be an issue with an upstream provider, however we are working to ensure this is resolved as quickly as possible.
Posted Aug 20, 2025 - 10:37 PDT
This incident affected: Web Application (Australia & New Zealand, International, United States).