Some admin users unable to log in

Incident Report for Elvanto

Resolved

We've resolved the issue - in some cases it may be up to an hour before logins or password resets will work correctly. We will continue to monitor and update if there are further issues detected.
Posted Feb 26, 2026 - 02:22 PST

Identified

We’re aware of an issue causing some Elvanto admin users to be unable to log in. We are working to correct this issue, and will have more updates forthcoming.
Posted Feb 26, 2026 - 00:19 PST
This incident affected: Web Application (Australia & New Zealand, International, United States).