Elvanto Accounts not loading

Incident Report for Elvanto

Resolved

We are seeing improved performance on the Elvanto website and API resources. Our teams will continue to monitor this closely, however this is resolved.
Posted Sep 17, 2026 - 05:55 PDT

Investigating

We're investigating an issue affecting the loading of Elvanto accounts.
Posted Sep 17, 2026 - 05:06 PDT
This incident affected: Web Application (Australia & New Zealand, International, United States) and API Service.