Emails not being delivered (or being delivered slowly)

Incident Report for Elvanto

Resolved

Elvanto emails are now sending. There may still be delays for the next few hours as messages are caught up. We’ll continue to monitor and ensure that all emails are sending as intended.
Posted Feb 17, 2026 - 01:26 PST

Identified

We’ve identified the issue causing the problem and are working to fix this as quickly as we can. We’ll share another update shortly.
Posted Feb 16, 2026 - 23:31 PST

Investigating

We’re investigating issues with Elvanto Emails not sending for many users. We’re investigating the root problem right now. We’ll continue to share updates on our progress as we resolve this issue.
Posted Feb 16, 2026 - 22:30 PST
This incident affected: Web Application (Australia & New Zealand, International, United States).