Issues loading Elvanto pages
Incident Report for Elvanto
Resolved
Our Engineering team has fully resolved this issue.
Posted Nov 06, 2024 - 17:02 PST
Identified
We are seeing that this is solely affecting the US server.
Posted Nov 06, 2024 - 16:56 PST
Update
We are continuing to investigate this issue.
Posted Nov 06, 2024 - 16:54 PST
Investigating
We are aware of issues loading Elvanto accounts and our Engineering team is working to solve this already.
Posted Nov 06, 2024 - 16:53 PST
This incident affected: Web Application (Australia & New Zealand, International, United States) and API Service.