Investigating Major Outage for Elvanto US Server
Incident Report for Elvanto
Resolved
We’re back! Our US systems are up and running once again. Thanks for bearing with us.
Posted May 20, 2023 - 03:30 PDT
Investigating
Elvanto is down for most US users. We’re investigating the root problem right now. We’ll continue to share updates on our progress as we resolve this issue. API Service remains operational in all regions.
Posted May 20, 2023 - 01:59 PDT
This incident affected: API Service and Web Application (United States).