All Australian customers with start-of-the-year grade progressions have been successfully completed.
Posted Jan 07, 2026 - 11:26 PST
Update
A small amount of grade progressions are still outstanding as we continue to complete this work - we will update here when we have reached completion.
Posted Jan 06, 2026 - 12:45 PST
Identified
We are continuing to process the delayed member grade progressions and will update here once we've confirmed that all progressions are completed.
Posted Jan 05, 2026 - 16:55 PST
Investigating
We're aware that some Australian customers have experienced a delay in member grade progressions and may only see some people in their organization have progressed as intended. We are working to rectify this and will update here once we've confirmed that all progressions have completed.
Posted Jan 05, 2026 - 11:38 PST
This incident affected: Web Application (Australia & New Zealand).