Issues with login and password resets

Incident Report for Elvanto

Update

As our teams have been monitoring, we're seeing users successfully login, and also reset their passwords when needed. There are some customers reporting issues not receiving a password reset email, and the cause of this is due to not having an email attached to their user. For these situations, another Admin will need to follow the steps in this Help Article and the User will be able to set a valid password. https://help.elvanto.com/hc/en-us/articles/17014456224151-How-to-Reset-a-Password-for-a-User-in-Elvanto

We will continue to update this page as needed to provide assistance.
Posted Feb 26, 2026 - 14:49 PST

Monitoring

Our Engineering teams have confirmed that Users are able to login and also reset passwords successfully and we are seeing that this is working as expected for customers. It will be required for most Users to update their passwords so following the "Forgot Your Password" steps on the login page will be needed. We have more detailed steps on that process in this Help Article: https://help.elvanto.com/hc/en-us/articles/21058609236247-How-to-Reset-Your-Elvanto-Admin-Password

We will continue to monitor and provide updates as needed.
Posted Feb 26, 2026 - 09:26 PST

Update

Our Engineering teams are reporting success in the tests for this fix and are releasing the change. We will provide another update once this is live for customers.
Posted Feb 26, 2026 - 08:24 PST

Identified

Our Engineering teams have identified the issue causing the trouble with password resets and are working to implement a solution.
Posted Feb 26, 2026 - 08:00 PST

Update

An available workaround for Elvanto users experiencing this would be to login to Tithely first and then use the SSO option to Elvanto. This option will work for those who have already setup that link.
Posted Feb 26, 2026 - 06:43 PST

Update

Our Engineering teams are continuing to work on the issue affecting the ability to reset passwords. We will provide the latest updates via this page.
Posted Feb 26, 2026 - 06:31 PST

Investigating

Our teams are investigating additional reports of trouble when attempting to perform a password reset. We will provide updates here.
Posted Feb 26, 2026 - 04:51 PST
This incident affects: Web Application (Australia & New Zealand, International, United States).