Identified Major Outage for Elvanto
Incident Report for Elvanto
Resolved
We’re back! Elvanto should be up and running. Thanks for bearing with us.
Posted May 15, 2023 - 17:29 PDT
Monitoring
Elvanto appears to be back up and running. We’re monitoring it closely to verify all issues are fully resolved.
Posted May 15, 2023 - 17:18 PDT
Update
We are currently working to restore service - thank you for your patience!
Posted May 15, 2023 - 17:15 PDT
Identified
We’ve identified the issue causing the problem and are working to fix this as quickly as we can. We’ll share another update shortly.
Posted May 15, 2023 - 17:13 PDT
This incident affected: Web Application (Australia & New Zealand, International, United States) and API Service.