Investigating Degraded Performance for Elvanto

Incident Report for Elvanto

Resolved

We’re back! Elvanto US and AU Regions should be up and running. Thanks for bearing with us.
Posted Dec 16, 2025 - 21:35 PST

Monitoring

After investigation, Elvanto US and AU Regions appear to be back up and running. We’re monitoring it closely to verify all issues are fully resolved.
Posted Dec 16, 2025 - 17:28 PST

Update

We’re noticing additional intermittent errors in the Elvanto AU Region as well. We’re still investigating the root problem right now. We’ll continue to share updates on our progress as we resolve this issue.
Posted Dec 16, 2025 - 16:47 PST

Investigating

We’re noticing errors loading Elvanto for US Region users. We’re investigating the root problem right now. We’ll continue to share updates on our progress as we resolve this issue.
Posted Dec 16, 2025 - 15:28 PST
This incident affected: Web Application (Australia & New Zealand, United States).